Are touchstones working?

Se habla deBug Collectors

Únase a LibraryThing para publicar.

Are touchstones working?

1LibraryCin
Dic 13, 2020, 1:03pm

The touchstones don't seem to be working for me today. Is it just me? Thanks.

2lilithcat
Editado: Dic 13, 2020, 1:11pm

Working now. Charles M. Blow

You might have hit on a short window when search was down. Touchstones involve a site search, so whenever site search is down, so are touchstones.

3LibraryCin
Editado: Dic 13, 2020, 1:26pm

>2 lilithcat: Thanks!

Seems a bit spotty. I have a long list that seems to be trying to work... But, it just timed out.

But a couple of posts I made with just one did work.

4Sergeirocks
Dic 18, 2020, 6:59pm

I've had no Touchstones since early October - totally dead.

5rodneyvc
Dic 18, 2020, 7:25pm

>4 Sergeirocks: An author one worked for me yesterday - Cordwainer Smith

6dchaikin
Dic 24, 2020, 7:28pm

They aren't working properly. !! The first time you enter a post, they work. If you edit that post, without refreshing, the stop working. If you then save that post, all touchstones revert to regular text.

7MarthaJeanne
Editado: Dic 24, 2020, 10:29pm

If you lose the touchstones in an edit, I find that deleting a character in the text outside the touchstones usually revives them. You will have to use 'others' again, but they will work.

Yes, it's a bug, but this is a work around util they get fixed.

8aspirit
Dic 24, 2020, 11:16pm

>7 MarthaJeanne: Has that workaround been working for you as often these past two or three months? I've been feeling as if we're losing touchstones in nearly every edit, and it seems to take more attempts to bring them back in each message.

9timspalding
Dic 24, 2020, 11:29pm

10aspirit
Dic 24, 2020, 11:38pm

>9 timspalding: Hello. If you edit your message (maybe by adding a word or a second touchstone), will the touchstone remain?

11MarthaJeanne
Dic 25, 2020, 3:12am

>8 aspirit: Worked for me yesterday.

12dchaikin
Dic 25, 2020, 11:57am

>7 MarthaJeanne: my touchstones have been going cold. That is the entire touchstone application shuts down while that thread is up. The solution is to refresh the page. I should add I'm using MS Edge.

13laytonwoman3rd
Dic 26, 2020, 3:32pm

>8 aspirit: I've had this issue with touchstones for at least the last couple months. If I edit a post with working touchstones, they all disappear. I've tried many little "tweaks" including re-entering the brackets, retyping the title or author name, and sometimes my edit had nothing to do with a touchstone in the first place, but the site doesn't even try to load them (no little spinning arrow) on the re-post.

>12 dchaikin: "The solution is to refresh the page" Do you refresh before or after re-posting an edited post?

14ulmannc
Dic 26, 2020, 4:24pm

I added 6 books to books read in December, https://www.librarything.com/topic/326986#n7355134,
yesterday and 4 worked fine. Two did not. I noticed a spelling error so I went in to edit it and when I saved it all my touchstones that were working are now gone. I tried one or two of the suggestions above with no success. This is my first failure like this, for what it's worth. The last time I really paid any attention to them was back in October, I think. I'm running Google Chrome on a Windows 10 Pro operating system that is up to date. FYI

15AnnieMod
Dic 26, 2020, 4:35pm

>14 ulmannc:

Yep, on a fritz again. I was updating my series list today and every update had been fine until the last one (and now all attempt to edit end up with "504 Gateway Time-out") where touchstones will usually be. Looks like search is broken. Again ;) Which causes the touchstones to get broken...

16laytonwoman3rd
Dic 26, 2020, 5:51pm

17Settings
Editado: Dic 26, 2020, 6:17pm

Touchstones have been hard to use for months. It's on and off, but I'll spend a while adding them to a post of books, then have them vanish when I try to edit the post to strike off a book or fix a typo.

Some books oddly won't touchstone, either. Had to backspace through the bracket on 24535874::Perestroika in Paris on my last post here like 5 times to get it to stop saying no results. Had the same issue before with The Taming of the Shrew.

18MarthaJeanne
Dic 26, 2020, 6:07pm

>17 Settings: There is another workaround. In the brackets type the work number, then two colons (::) followed by the title you want to see.

19Settings
Dic 26, 2020, 6:17pm

>18 MarthaJeanne:

Thank you, a bit more time consuming but probably worth it in the long run. Reselecting the correct works on a long post whose touchstones vanished is also time consuming.

Not working at the moment and can't tell if it's a site wide issue or I'm doing it wrong, but I get the concept, I'll figure it out eventually haha.

20MarthaJeanne
Dic 26, 2020, 6:27pm

>19 Settings: I just did one that way and it took much longer than I'm used to, but it did work in the end.

113348::Islandia

Islandia

21dchaikin
Dic 26, 2020, 6:57pm

>13 laytonwoman3rd: I save the post (if there are any changes to be saved), then refresh the page and then select edit. Typically it sort of reactivates.

Note: This isn't about the "504 Gateway Time-out", like in >15 AnnieMod: (I do get this too - but I consider it "normal"). This is about when the touchstone tool simply doesn't work and won't active.

22laytonwoman3rd
Editado: Dic 26, 2020, 8:03pm

Is there a limit to how many touchstones can load in one post? That 504 Gateway Time-out only seems to happen with long lists of titles in one post.

23aspirit
Editado: Dic 26, 2020, 11:27pm

===Below are touchstones.

CinderellA.I.
Interstellar Cinderella
Ever After

Above are touchstones.====

The generation of all three touchstones took about two minutes. That's not seconds, but minutes, timed.

On the first edit, I can see the touchstone below the text box... and the touchstones remain in the message after saving.

On the second edit, the touchstone links don't appear below the text box. They don't appear from fiddling with the titles or deleting to re-enter the brackets. Waiting two minutes doesn't bring about their appearance. The Preview feature doesn't show the links. There's also no waiting icon or error message.

The links don't return in the third edit, either. I've now spent more than ten minutes on this one message.

24dchaikin
Dic 27, 2020, 11:04am

>23 aspirit: Thanks! Apologies for the ten minutes, but you captured the problem exactly.

25laytonwoman3rd
Dic 29, 2020, 9:33pm

>21 dchaikin: Thanks...I was able to use that method to get back the touchstones in a list of over 70 titles. I cut the list from the post and saved it off-site. Then I added them back in batches of ten, refreshing the post before each new entry. Tedious, but it worked.

26bergs47
Editado: Dic 30, 2020, 8:44am

Touchstones, Author searches and Work searches have been erratic from 13:40 till 15:40 (GMT +2). Even got Gateway 504 from touchstones a number of times

27lilithcat
Dic 30, 2020, 9:09am

>26 bergs47:

Site search is down. That affects touchstones.

http://www.librarything.com/topic/295468

28BookConcierge
Dic 31, 2020, 10:05pm

Thursday, 12/31/20 at 21.05 CST

I am able to use the site search just fine. But Touchstones are not working.

29lilithcat
Dic 31, 2020, 10:39pm

Lady into Fox, by David Garnett

Seems to be okay now.

30ffortsa
Ene 15, 11:06pm

Touchstones are still not working consistently for me. Most of the time i can see them on original entry, but not if the post is updated. They disappear, or in some cases are present for only the first word in the title, and then there is no resolution because the title doesn't exist.

31John5918
Ene 17, 11:25pm

As far as I can see, Touchstones work ok when I first post a message, but if I edit it (even if the edit does not involve the Touchstones at all), they then disappear when I click "Save message". Latest example for me is post #6 at http://www.librarything.com/topic/328747#unread

32ffortsa
Ene 18, 6:15pm

>31 John5918: Yep, still. In addition, the little check mark in the touchstone list at the end of a thread is not consistently recognizing when I have read or reviewed a book, even when the touchstone itself is present. Connected?

33AnnieMod
Editado: Ene 18, 6:54pm

>32 ffortsa: The lack of check at the bottom/on the right is a different bug - it does not show up when it is supposed to be grey (green, blue and purple work) since Talk was changed. It had been reported in another bug report.

34humouress
Editado: Ene 19, 12:10am

I have a couple of issues that may (or may not) be linked to this.

1) If I type the links to a few posts in one posts (ie >post number), the links fail and I just get a list of numbers. I'm seeing this both on my iPad Air (Safari/ iOS 12.something) and on my desktop (Safari/ OS Big Sur) (and also Firefox).

See https://www.librarything.com/topic/328123#7366303 for example.

2) I'm finding touchstones (the ones that do work) very slow to load, even from my catalogue pages.

35John5918
Ene 21, 11:42pm

Just wondering whether there's any feedback on the disappearing Touchstones issue?

36aspirit
Ene 22, 10:15am

>35 John5918: From Tim's sole message above, I'm guessing he's told himself we're all imagining the problem. That's really what it looks like to me, and it's as disappointing as the broken touchstones. I feel like this is going to go the way the sitewide disappearing editions/works issue.

37lorax
Editado: Ene 22, 11:07am

To repeat Tim's experiment, in a more relevant manner:

Mark Twain

Hey, look, a touchstone! Now let's edit the message.

38Settings
Editado: Ene 22, 3:19pm

Finding touchstones so broken that I'm done trying to use them until there's some kind of announcement that they've been fixed. Will use bold or italics instead.

39aspirit
Editado: Ene 22, 3:12pm

>37 lorax: expanded experiment:

Authors

Mark Twain
Jean Webster

Works

Tom Sawyer
Daddy-Long-Legs

Oddly, it took me several minutes of fiddling with Mark Twain's touchstone to get it generate, while the others came up immediately.

Now let's see what this message looks like with an edit (this additional line).

40aspirit
Ene 22, 3:15pm

>37 lorax: and >39 aspirit: Touchstones are working in some messages. That's the good news.

The touchstones haven't returned to >23 aspirit: though. More importantly, members are obviously continuing to struggle enough to give up on the feature.

41MarthaJeanne
Ene 22, 3:19pm

Several times lately I've had to give up on my original message and post a new one with just the touchstones.

42lorax
Ene 22, 4:00pm

Oh, definitely! I was just testing whether or not editing *always* broke touchstones - since it doesn't, it's unfortunately going to be a harder bug for them to track down.

43LibraryCin
Editado: Ene 22, 9:17pm

Most of the time they work for me.

I had a post in mid-December, I think, that was a list of books. That one didn't work. Even the first time. Editing didn't help.

More recently I also had one that was initially fine (just one touchstone in that post), but I went in to edit something else and I lost the touchstone.

ETA: I am, however, going on memory.

44humouress
Editado: Ene 23, 1:30am

Well, I've just written a post where the touchstones were definitely working but then I went back and edited it and they've all disappeared.

https://www.librarything.com/topic/328042#7396406

Safari/ Big Sur

45John5918
Ene 25, 12:59am

I've just edited my post #40 in http://www.librarything.com/topic/326099 and I notice that the author touchstone has worked OK. Can we hope that the problem is now fixed, or is it still patchy, working some of the time only?

46kristilabrie
Ene 25, 9:33am

>45 John5918: I want to test this further to make it easier to pin down/fix, but I think it may only be happening for posts with many touchstones. I need to find out just how many is the tipping point...

47MarthaJeanne
Ene 25, 9:37am

>46 kristilabrie: Actually it seems very variable, sometimes even a single touchstone not appearing on the first try.

48lorax
Ene 25, 9:55am

kristilabrie (#46):

I think it may only be happening for posts with many touchstones. I need to find out just how many is the tipping point...


That's how it used to work. Many people have reported encountering it for cases with a single touchstone. The problem is that it's sporadic, which suggests it may be related to the general search flakiness - if they happen to edit the post when search is down or slow, even a single touchstone is lost.

49kristilabrie
Ene 25, 10:09am

>48 lorax: Ugh, yeah. That's definitely a complicating factor. Okay, thanks for the extra info (and to you as well, MarthaJeanne!)

50NinieB
Ene 25, 11:48am

>49 kristilabrie: Agreed with lorax and MarthaJeanne. In my experience it's editing a post that seems to disrupt touchstones.

51mysterymax
Feb 2, 9:18am

Sometimes they work - on short messages. But my first entry which is books read in January, they don't. I'm going to quit trying. I fooled around trying to make them work when I had the first problem without success so I'm not going to bother. It's very frustrating.

52mysterymax
Feb 2, 9:44am

And then I went to my email and when I came back they were working.

53MarthaJeanne
Feb 2, 9:48am

I was quite shocked today to see that a few touchstones stayed after an edit. Certainly wasn't working that way yesterday.

54dchaikin
Feb 2, 11:31am

>46 kristilabrie: no. Same thing happens with a single touchstone.

I notice lately that sometimes i get one edit with touchstones working. Then the second edit they die.

Solution is still to refresh page first, then edit, check touchstones and save. This has worked 100% of the time for me.

55MarthaJeanne
Editado: Feb 2, 11:45am

>54 dchaikin: Thank you. Yes, that worked on the one that just didn't.

>46 kristilabrie: That was two touchstones.