request for feedback/poking/prodding

Se habla deHacking LibraryThing

Únase a LibraryThing para publicar.

request for feedback/poking/prodding

Este tema está marcado actualmente como "inactivo"—el último mensaje es de hace más de 90 días. Puedes reactivarlo escribiendo una respuesta.

Ene 11, 2014, 4:41am

Hello all,

I've been working on a GreaseMonkey script to support autocompletion of one's own tags (that works with commas). Before advertising it in the threads where it's been requested, I was hoping y'all could help me out, basically as guinea pigs. The script is here: Basically, I would really appreciate any and all feedback, especially regarding:
  • any places to add tags that I missed (see supported places below)
  • performance issues (for me it behaves decently even with crazy-high tag amounts (except for ThomasKleinert's, whose seem to take quite long to load), but maybe that's just my set-up)
  • any other issues you find with it (e.g. I couldn't test if it works on private libraries)
  • any issues you might see with the code itself
Here are the places it currently works: 1) "Add Books" page, 2) catalog pages (the double-clicked form), 3) the tag add/remove form in Power Mode, 4) "Edit book" page, and 5) the "Your Book Information" section of book pages.

Should work in FF and Chrome, but doesn't work in Opera. Sorry.


Ene 13, 2014, 11:59pm

Installed in, in Firefox - I'll try it out.

Ene 14, 2014, 1:51pm

Oh, I would love this feature and am happy to be a guinea pig. I assume I install it in Chrome using TamperMonkey? I'll do that tonight when I get home.

Ene 14, 2014, 4:28pm

Thanks, y'all! As for the Chrome question, yes, that's what I use for these scripts, TamperMonkey.

(In the past I had some issue with Chrome not wanting to accept a script from, so I think I had to get around it by grabbing the script's source code and pasting it in as a new script in TamperMonkey, but the other day I tested just using the green install button and it seemed to work ok.)

Editado: Ene 15, 2014, 1:22am

If I add a tag to a field that already has tags in it, what the script offers is the last tag entered; if I enter the new tag anywhere other than the end of the list, it doesn't notice my typing or offer anything. Also, the offer of the last tag covers 90% of the buttons - at least once I clicked Cancel instead of Save because I couldn't tell which button was which. This is in a double-clicked field in the catalog and in the field on the main book page.

In the same two places, if I choose a tag off the list it enters that tag, space, comma. Which is great if I'm going to enter another tag, and very annoying if I was just entering the one. Not sure what you can do about it...though personally I'd rather do without the comma, typing it myself when entering a whole list of tags. This is probably mainly because I seldom do, there - I enter lists of tags on the Add Books page, but I add to (and subtract from) my tags in the catalog and main book page. Having to delete two characters every time I add a tag is quite annoying. Couldn't it add ", tag" instead of "tag, "? Then of course you have the problem of the script figuring out when you want to add a new tag...

OK...went into a doubleclicked field, started typing at the end of the list. After I'd typed 3/4 of the word, the list came up; I ignored it and finished typing, hit return to save. The list is still there. I scrolled up and down the page, tried reopening and saving the tag field, tried opening other tag fields - still there. It stayed until I picked a tag (which didn't write itself anywhere, I didn't have a field open).

Ene 15, 2014, 3:12am

And...I deleted a tag, the last one in a list (on the main book page). The list of suggestions popped up for the new last one, and covered the Cancel/Submit buttons. Since hitting Return on that field leaves an extraneous character in there (which is a bug, but not one that's gotten any notice), I had to click around until the list disappeared so I could get at the Submit button. The first time, I accidentally hit the list when I went to click - didn't notice it was there - and it replaced my tag with the one I hit (so I had to click Cancel and redo my delete).

Ene 15, 2014, 9:55am

OK, real problem. While the script is enabled, I can't go to another page in a collection - I bounce back into All Collections every time. Nor can I sort. I bugged it, because I couldn't figure out what was going on - then it occurred to me that the problem popped up just about the time I installed the script. Disabled it, and everything works fine. No idea where the problem lies (I haven't looked at the script), but that's something that will need fixing.

I'm in the latest Firefox on Win 7 Pro.

Editado: Ene 15, 2014, 7:48pm

Using latest firefox on Windows 8.1 (erg) I am also experiencing the collections problem as per #7. Also, while typing tags if I hit the enter key the field closes like normal, but the drop down menu remains on the screen until I click on it, so that's weird.

What I do like is that it doesn't just select tags that start with the typed string. Because of my tagging conventions I often think of a tag by one of the words in the middle, so that's REALLY useful for me.

What I would like is the ability to multi-select if more than one appropriate tag is visible.

I will have to turn it off temporarily because of the collections thing, but I am happy to see the effort.

Edit: I'm also experiencing the same problems as #5 re: trying to insert a tag in the middle of a group of tags. I don't mind the comma thing since it will disappear when the field is closed.

Edit 2: I didn't test it in power edit. I don't often use it to add tags anyway because new tags are always appended to the end which isn't usually where I want them.

Ene 15, 2014, 10:23pm

Does the comma just disappear, or do you get a blank tag added? I didn't test, but that's what I've seen previously when a random extra comma got added.

Editado: Ene 15, 2014, 11:28pm

>9 jjmcgaffey: I didn't get a blank tag added. I often forget to delete the last comma when I copy/paste my tags and don't have a problem. I can't say that I've never had a blank tag, because I think I have once or twice in the past, but if so it was from some other weirdness.

Also, I turned it back on for a moment to test !, ?, and @ . ! and ? work, but @ doesn't.

Ene 16, 2014, 12:52pm

The basic functionality is excellent. I will definitely use this, especially if you can get the bugs worked out.

One small issue. On the add books page, when I arrow down to a tag in the list and hit tab it enters the tag and then moves to the next button on the page. I would much prefer it to stay in the tags box, just at the end of the list. That's how it seems to work in the book information box on the work page.

Ene 18, 2014, 11:17am

5-11 >
Thank you all for the great, incredibly detailed feedback and bug reports. It makes me very glad I posted this feedback request instead of just announcing the script as ready. :-) I have been on the road so haven't been able to dedicate a good chunk of time to this, but have been working on things as I have a moment. I think some of the issues may simply not have a fix :-( while other should definitely be solvable. Will have to post more on all this later, as my road trip continues ...

Editado: Ene 25, 2014, 5:00am

Ok, I've made several changes/fixes. Thanks again for the feedback. Version 3 is now up at the same place:

The bad
  • ... if I enter the new tag anywhere other than the end of the list, it doesn't notice my typing or offer anything
    Sadly, I'm not sure there's much to be done about this. The contraption isn't terribly aware of where you've started typing; I think it generally assumes you're at the end, and I think it would very difficult (if possible) to ever figure out "I'm starting a new tag between two others". So: this script might only be useful for "additive" tag editing. :-(
  • Related: ... because new tags are always appended to the end which isn't usually where I want them
    I wasn't even aware that one could expect tags to stay in order. Again, I fear this script might not be too useful if you're editing existing tags and wanting to add things in the middle.
The so-so
  • ... the last tag covers 90% of the buttons
    It is possible to display the list of suggestions in a different location (e.g. to the right of the input/textarea), but when I tried this, it felt/looked very odd (especially when arrowing down to select something at right). Is it an acceptable compromise to live with just "carefully clicking somewhere else" to get the thing to go away if you need to see the buttons? Other ideas?
  • ... if I choose a tag off the list it enters that tag, space, comma.... very annoying if I was just entering the one
    I removed this for the latest version; now you've gotta type the comma yourself. macsbrains is right, no blank tags get added if you save without removing extraneous commas. Though I think this change can exacerbate the "it's always suggesting the last tag in the list" problem. I also kind of found the automatic comma addition more convenient since I wasn't worried about it creating blank tags. I'm curious: do you think your (understandable) annoyance/concern about the comma is of the "surmountable after testing things out" variety, or did it create too much of an off-putting feel?
  • What I would like is the ability to multi-select if more than one appropriate tag is visible.
    While, I think this is *possible*, it's not coding I want to try :-) and it would also probably conflict with the expectations of others who expect clicking to add right away. So for now you're stuck with type/arrow-down/enter, type-again/arrow-down/enter, etc.
The good
  • OK, real problem.... I bounce back into All Collections every time
    Sorry about the headache of having to bug that and all. But thank you for finding it. Since I don't do collections, I never would have noticed. This should be fixed now. I finally found a way better URL to get one's tags from (the old one was changing your collection cookie in order to view all of your tags).
  • ... while typing tags if I hit the enter key the field closes like normal, but the drop down menu remains on the screen
    Should be fixed now.
  • ... when I arrow down to a tag in the list and hit tab it enters the tag and then moves to the next button on the page
    Should finally be fixed. Now it behaves similar to Enter. Tabbing without any of the suggestions focused/selected will do what tabbing would do if autocomplete weren't there at all. Hope that's ok.
  • ... ! and ? work, but @ doesn't
    None of them were working for me. :-) Should be fixed now. Details: Now it matches based on "word boundary" (which I think doesn't include punctuation), beginning of tag, or preceded by space. So I think searching for "m" will find "mooched" and "book mooched" but probably not "book:mooched" (and "m" should match both "mooched" and "mooched").
The new
The list now displays, in gray next to the tag, the number of times you've used it. Hopefully that's useful and not problematic.

And a question
Currently it's displaying the suggestions in frequency order, but I could also do alpha (in time, I think I could make this configurable so you could change). Is there a preference?

Ene 26, 2014, 12:39am

>13 omargosh: I'll install the new version when I'm at my main computer and let you know how it's working.

Ene 26, 2014, 2:57am

If it doesn't create a blank tag, then sure, no problem with the comma. I can see how it would be useful, certainly, especially if you're adding a whole list.

And - I think I'd prefer alpha. Well....hard to decide. There are some tags I use constantly - the problem is that aside from those, the rest of the tags in frequency order would be essentially random. I'd have no idea where in the list some of my medium-common tags would be, which makes it really hard to find them - if I have to type, say, 4 letters of a 7-letter tag (and then scroll the list and click, or arrow-down and tab/enter), I might just as well type the whole thing (though it would still be useful for getting the details right (capitalization, pluralization, etc).

And yeah, since the "alphabetize my tags" option went away, tags stay in the order in which they're typed. Some people care about the order because they sort by them; some just prefer them in the same order for visual scanning. I don't care much, except when I do...wish the alphabetization option would come back (it was just the display, didn't actually move the tags around. Hmmm, wonder if a script could fix that?).

I'll try it out, but later.

Ene 27, 2014, 12:15pm

Ok, I've made more updates (script page): 1) The trailing comma is back (though now I'm just ambivalent about it). 2) It now works on the "manual entry" page. 3) Sorting order is now configurable. Here's a screenshot:

It shows up at the bottom of the list, but only when you put your mouse over the list (it seemed annoying when it was always there). I slightly suspect that something about the sorting option has made performance worse for those with large tag sets (thought it's hard to know if that's just my browser or LT being slow at the moment). Of course, let me know if y'all have problems with it. Thanks.

Ene 29, 2014, 2:11am

So far so good. No major bugs that I've encountered yet, but I haven't used it in all places. I do notice that it is quite a bit slower than it was previously, so if I know the tag, I've usually finished typing it before the list is generated. But it's still useful for me, especially because I like long tags that I never manage to type the same way twice.

Mar 23, 2014, 5:20pm

Hi there,
I've installed this script, and can see that it's running on the pages I expect, but it doesn't seem to be working. I'm wondering if you have any updates?


Mar 23, 2014, 6:16pm

Hi Laura,

Thanks for the bug report. I'm guessing that it's because you're using the https version of LT, which apparently doesn't allow the script to pull in the http versions of the JS and CSS it needs. I've updated the script (still at to pull in https instead. Let me know if it still doesn't work for you. Thanks!